Wprowadzenie do Zend Framework

     Nauka Zend Framework

    appendix

     Przewodnik po Zend Framework


  • Zend_Gdata
  • Zend_Http
  • Zend_InfoCard
  • Zend_Json
  • Zend_Layout
  • Zend_Ldap
  • Zend_Loader
  • Zend_Locale
  • Zend_Log
  • Zend_Mail
  • Zend_Markup
  • Zend_Measure
  • Zend_Memory
  • Zend_Mime
  • Zend_Navigation
  • Zend_Oauth
  • Zend_OpenId
  • Zend_Paginator
  • Zend_Pdf
  • Zend_ProgressBar
  • Zend_Queue
  • Zend_Reflection
  • Zend_Registry
  • Zend_Rest

  • Zend_Search_Lucene
  • Zend_Serializer
  • Zend_Server
  • Zend_Service
  • Zend_Session
  • Zend_Soap
  • Zend_Tag
  • Zend_Test
  • Zend_Text
  • Zend_TimeSync
  • Zend_Tool
  • Zend_Tool_Framework
  • Zend_Tool_Project
  • Zend_Translate
  • Zend_Uri
  • Zend_Validate
  • Zend_Version
  • Zend_View
  • Zend_Wildfire
  • Zend_XmlRpc
  • ZendX_Console_Process_Unix
  • ZendX_JQuery
  • Translation 21.3% Update 2011-11-16 - Revision 24356 - Version ZF 1.11.x

    Dodatek A. Wymagania Zend Framework

    Zend Framework wymaga interpretera PHP 5 z serwerem pozwalającym na poprawną obsługę skryptów PHP. Niektóre funkcjonalności wymagają dodatkowych rozszerzeń lub funkcji serwera; w większości przypadków framework może być użyty bez nich, jednak może ucierpieć na tym wydajność, a niektóre poboczne fukncjonalności mogą nie działać w pełni sprawnie. Przykładem takiej zależności jest rozszerzenie mod_rewrite serwera Apache, które może być użyte do utworzenia "przyjaznych URL" jak "http://www.example.com/user/edit". Jeśli rozszerzenie mod_rewrite nie jest aktywne, ZF może być skonfigurowany w taki sposób aby obsłużyć adresy URL w postaci "http://www.example.com?controller=user&action=edit". Przyjazne URL mogą być użyte aby skrócić adresy w celu polepszenia ich czytelności lub dla potrzeb optymalizacji pod kątem wyszukiwarek internetowych (SEO), jednak nie mają one bezpośredniego wpływu na funkcjonalność aplikacji.

    A.1. Wersja PHP

    Zend zaleca wersję PHP 5.2.3 lub wyższą z powodu znacznego zwiększenia bezpieczeństwa i wydajności, jednak Zend Framework do działania wymaga wersji PHP 5.1.4 lub wyższej.

    Zend Framework posiada obszerny zestaw testów jednostkowych, które możesz uruchomić za pomocą biblioteki PHPUnit 3.0 lub wyższej.

    digg delicious meneame google twitter technorati facebook

    Comments

    Loading...