Introducción a Zend Framework

 Aprendiendo Zend Framework

Apéndice

 Referencia de Zend Framework


  • Zend_Gdata
  • Zend_Http
  • Zend_InfoCard
  • Zend_Json
  • Zend_Layout
  • Zend_Ldap
  • Zend_Loader
  • Zend_Locale
  • Zend_Log
  • Zend_Mail
  • Zend_Markup
  • Zend_Measure
  • Zend_Memory
  • Zend_Mime
  • Zend_Navigation
  • Zend_Oauth
  • Zend_OpenId
  • Zend_Paginator
  • Zend_Pdf
  • Zend_ProgressBar
  • Zend_Queue
  • Zend_Reflection
  • Zend_Registry
  • Zend_Rest

  • Zend_Search_Lucene
  • Zend_Serializer
  • Zend_Server
  • Zend_Service
  • Zend_Session
  • Zend_Soap
  • Zend_Tag
  • Zend_Test
  • Zend_Text
  • Zend_TimeSync
  • Zend_Tool
  • Zend_Tool_Framework
  • Zend_Tool_Project
  • Zend_Translate
  • Zend_Uri
  • Zend_Validate
  • Zend_Version
  • Zend_View
  • Zend_Wildfire
  • Zend_XmlRpc
  • ZendX_Console_Process_Unix
  • ZendX_JQuery
  • Traducción al 26.9% - Actualizado el 2011-11-16 - Revisión 24249 - Versión ZF 1.11.x

    Apéndice A. Requisitos de Zend Framework

    Zend Framework requiere un intérprete PHP 5 con un servidor web configurado para manejar scripts PHP correctamente. Algunas características requieren extensiones adicionales o características de servidor web; en muchos casos el framework puede ser utilizado sin ellos, aunque el rendimiento puede sufrir o las características auxiliares pueden no ser completamente funcionales. Un ejemplo de dicha dependencia es mod_rewrite en un entorno Apache, que puede ser utilizado para ejecutar "pretty URL " como " http://www.example.com/user/edit ". Si mod_rewrite no está habilitado, Zend Framework puede ser configurado para apoyar las URL como " http://www.example.com?controller=user&action=edit ". La pretty URL , puede ser utilizada para acortar las URL de representación textual o para la optimisation de los motores de búsqueda( SEO ), pero no afectan directamente a la funcionalidad de la aplicación.

    A.1. Versión de PHP

    Zend recomienda PHP 5.2.3 o superior por mejoras en la seguridad críticas y en el rendimiento, aunque Zend Framework requiere sólo PHP 5.1.4 o posterior.

    Zend Framework tiene una extensa colección de unidades de prueba, que puede ejecutar utilizando PHPUnit 3.0 o posterior.

    digg delicious meneame google twitter technorati facebook

    Comentarios

    Loading...